Previous Page | Next Page

Can't play .str by mistamontiel at 12:28 AM EDT on July 12, 2016
Just updated foobar components , why is the .str format still unknown ?

Referring to Dreamcast's Gauntlet Legends

EDIT: SOLVED updated foobar out of v1.3.6 to v1.3.10 . LOVE the seamless convert feature for everything keep doin it !!!

edited 1:29 AM EDT July 12, 2016
EDIT 2 by mistamontiel at 10:11 PM EDT on July 15, 2016
Can't edit previous post .. actual problem was had a disc in drive with CDDA .. conflict
by kode54 at 3:19 AM EDT on July 16, 2016
foo_adpcm's .str/.xa reader attempts to access raw optical drives to read unreadable raw XA files. It detects them by walking the iso9660 filesystem of all mounted optical media.

E: FFmpeg support in my repository, it needs platform specific code to be built anywhere, though.

edited 1:09 AM EDT July 17, 2016
by AnonRunzes at 7:15 PM EDT on July 19, 2016
Is this format supported yet?
Here's the .msa file, by the way.
by kode54 at 6:13 PM EDT on July 20, 2016
MSF Codec ID #5... no idea what that is, nothing supports it yet.
by AnonRunzes at 3:24 PM EDT on July 31, 2016
How can I figure these Gamecube ADPCM files out? I mean, channels, sample rates, interleaves, coefficients, etc.

And what am I supposed to do with this .stm file anyway?

And what about this file from the PS2 version of TransWorld Surf? It crashes right after I rename the extension to .stma and I put it to play on foobar2000.

And finally, with yet another edit, here's the audio file from the Xbox version of the same game:

Keep in mind that these files posted above aren't really supported by vgmstream yet, so if anyone can implement these or at least do something to make it work on it, I'll be grateful.

edited 3:06 PM EDT August 1, 2016
by Arymond at 5:24 PM EDT on August 1, 2016
this MSF File only Plays Mono when i'm sure it should be Stereo.

FOZ_MAGNET.msf (from the Ps3Games)

Should be saying "N,S Magnet on" plays fine in game too.

Should sound like this?

SID_FOZ00_FOMECHANGE00.rwav (from one of the Wii Games)

Also these HCA Files Don't play correctly.

edited 5:35 PM EDT August 1, 2016
by kode54 at 10:19 PM EDT on August 1, 2016
Those HCA files are encrypted, and will not play correctly, as VGMStream is hard coded to use the PSO2 keys for encrypted files.

You'll need to use something to decrypt them first, presumably also acquire the keys from the game's code.
by Arymond at 11:35 PM EDT on August 1, 2016
hm... do you know where i'd find that in a Android Game?
by Dais! at 6:18 AM EDT on August 5, 2016
This is probably a dumb question, and it concerns a subject I don't really understand, but...

Could vgmstream and derivative implementations be instructed to scan the files in a directory, performing hash checks on stream files against an additional text-type file (like an m3u) in order to 'fake' tags, like is done with GBS/HES/KSS/etc?

Like you have a Speed King 2045 playlist, SLPM-86013.m3u or something.
After the chunk of information applicable to all files (game, company, etc), the first line of the playlist proper might be something like
XA.abcdef99."Opening CG"."Mutsuhito Izumi"
(note: not an actual proposed format for entries)

And then the music player would scan the directory of the playlist for XA files, make a temporary index of their hashes and stick the file with the checksum of "abcdef99" in the corresponding spot on the program's playlist, and the 'tags' would display the right data, even if XO_001_00A.XA has been renamed 420 blaze it.XA

I'm not asking for this to be done - I barely know how to describe it. But I'd love to know if it is feasible or just absurd. The idea's been bugging me for years.
by AnonRunzes at 7:05 PM EDT on August 23, 2016
I'm not done with my issue with vgmstream. Not yet.

I mean, the thing just doesn't support even one .mtaf file... Here's the sample:

Well, it DOES support but when I try the file on the test.exe tool or even on a foobar2000 component, it crashes right away. I hope someone looks into this issue as well.

EDIT: And I forgot to state that this file came from an PS3 version of a game called Metal Gear Solid HD Collection.

edited 7:28 PM EDT August 23, 2016
by kode54 at 8:35 PM EDT on August 24, 2016
I pushed a change to both Github and GitLab that fixes this file. I'll roll out binaries later.
by AnonRunzes at 10:03 PM EDT on August 24, 2016
Huh? But what about the rest? Aren't you missing something?
by 47iscool at 2:16 PM EDT on August 25, 2016
Anyone else having an issue with vgmstream not displaying the correct song lengths?

I reverted to an older version, just to make sure that foobar wasnt the problem.
by AnonRunzes at 10:33 PM EDT on August 31, 2016
And finally, here's an .sgd file that plays like shit. I hope that's enough for you!
by 47iscool at 11:27 AM EDT on September 4, 2016
Nevermind, the fault was mine.
idsp error by Wildbreed at 7:51 PM EDT on September 4, 2016
Hello Guys First off

Mega LinK

I wanted to extract wavs from the nus3bank file

I was using nus3bank editor for the job

however when i try to export the goes to vgmstream for the conversion and gives an error that it cant convert..

I have provided the editor in the "Bank" folder as well as the said nus3bank file from the vita...the editor requires python

Any help would be appreciated
by KirbyKFC at 8:18 AM EDT on September 6, 2016
I got an error for converting a nus3bank file which is from a PSvita game dump.

The result from Google is that there is no information to decode this kind of audio files.

I really need help.
by kode54 at 7:02 PM EDT on September 6, 2016
nus3bank files from PSVita titles contain ATRAC9 audio, which you'll need components from the Sony SDK to decode.

I have found these components, but I will not support them in VGMStream. I will only support a clean room reverse engineering effort.
by Nisto at 3:44 PM EDT on September 9, 2016
Does vgmstream support the .SVAG files from PS2 World Heroes Anthology? The magic is "VAGm", and I think these files are all stereo, but I haven't verified it.

Sample file:!m0JAnBbI!JSxAFX-Rpq4Tl5gNaVrE8A-IcJ3vLltGU4q7sfEjue0

edited 8:28 PM EDT September 9, 2016
by Nisto at 9:20 PM EDT on September 13, 2016
Bump. See last post on previous page.

edited 12:07 AM EDT September 14, 2016
by PewnyPL at 9:57 AM EDT on September 16, 2016
Question, was the MCA type 5 (Monster Hunter 4 U) issue ever solved? I found the seemingly newest version of vgmstream (r1050-50-gd22a43b) but nearly all files have a lot of static in it.
by hcs at 4:58 PM EDT on September 17, 2016
Just want to get this off my chest: I'm pretty sure that most of the MS IMA decoders are broken, as they don't count the extra sample from the frame header. But I don't want to fiddle around with it and find something that uses all the different variations and try to tell by ear whether it is correct and deal with loop points being off and everything... maybe they just ignore that sample and if it was an issue it would have been noticed years ago.

edited 5:19 PM EDT September 17, 2016
by Nisto at 12:31 AM EDT on September 18, 2016
So no one is going to bother with the VAGm .svag files... ?

It seems like it would be EASY to add support considering there are already many VAG variations supported, and most of that code is in one place. I would probably try implementing it myself, but building vgmstream for foobar2000 seems like a ROYAL PAIN (yes I've actually tried), and I can't even find any official instructions on how to build vgmstream whatsoever, so I have no way to test if I even did things right in the end...

There's really nothing unusually complicated about the format.

Header size is 32 (0x20) bytes

Channel count is 2 (this may actually vary though, I'm consistently seeing 0x02 in the World Heroes Anthology headers, and the stream size is specified for each channel)

Sample rate is at offset 0x08

Interleave is 16 (0x10) bytes

I also noticed World Heroes Anthology has already been uploaded by someone on joshw's server. Now, really, what's the point of having these .svag files up there if nothing can play them?
by AnonRunzes at 12:43 AM EDT on September 18, 2016
Well, either kode54 or hcs might notice your whining about these files. That is, if they even have the determination into looking at your issue.

edited 12:43 AM EDT September 18, 2016
by AnonRunzes at 11:18 AM EDT on September 18, 2016
In the meantime let's flood this thread with samples.

edited 11:24 AM EDT September 18, 2016
by Nisto at 2:16 PM EDT on October 27, 2016
Any chance we can get support for MSF in the foobar2000 version? It's supported in the Winamp version.. :(
by AnonRunzes at 3:00 PM EDT on October 27, 2016
@Nisto - Seems like hcs or kode54 thinks this thread are less revelant to them than their vgmstream' repositories.
by bnnm at 5:53 PM EDT on October 27, 2016
As a learning exercise I added support for World Heroes / FF Battle Archives 2 .SVAG to kode54's github.

Works well in test.exe, but I have yet to investigate how to build the foobar2000 plugin (I take you can use Visual Studio 2015 Community, all +10GB of it).
For now you'll have to wait until kode54 recompiles it.
by Nisto at 6:35 PM EDT on October 27, 2016
Ahh, great, thank you bnnm. Yeah, compiling it is really the harder part here..
by AnonRunzes at 6:38 PM EDT on October 27, 2016
And what about the samples I posted? You're missing someth- *suddenly realizes the links I posted are dead* Whoops!
by Feldspar at 11:35 PM EDT on October 30, 2016
Do you plan to support the AT9 file?
by kode54 at 12:06 AM EDT on November 1, 2016
Not unless someone makes an open source, clean room reverse engineering of the decoder. I will not support or require users to "Go Google up this SDK license violation of a file". The day I do that is the day I find hosting that is 100% invulnerable to DMCA takedown notices.

Oh, right, and the stolen library solution is only applicable to 32 bit Windows, and I support more than just that.

edited 12:07 AM EDT November 1, 2016
by Kurausukun at 4:37 AM EDT on November 2, 2016
The latest update to the foobar plugin has stopped giving me loop points for nus3banks. I'm not sure if this is intentional or not, given that Moosehunter and I found out vgmstream was calculating the loop end wrong for idsps (and thus also nus3banks) recently.
by kode54 at 7:09 PM EDT on November 2, 2016
Nothing has been changed with regard to that format. Verify the change with a test.exe built with the same library code.
by Kurausukun at 12:47 AM EDT on November 3, 2016
My bad, sorry. I made a dumb oversight.
by bnnm at 2:24 PM EST on November 8, 2016
@Nisto - I was able to build the foobar plugin, maybe I could put together some notes.
But kode54 already updated it on his site anyway, plays SVAGs now.

Many song loops just repeat the whole song, but I think that's the correct behavior, you should recheck though.
by Nisto at 4:37 PM EST on November 8, 2016
Yep, I noticed the update like a week ago. Thanks again!
by bnnm at 2:34 PM EST on November 19, 2016
I was thinking of uploading to the repo my precompiled (trimmed) FFMpeg .DLLs/includes so vgmstream can be compiled to use a few extra formats, but the licensing stuff is making my head spin.
You can even compile it in LGPL or GLP2/3. :S

Anybody knows if it's allowed and stuff?

(does vgmstream even have a license?)
by hcs at 6:40 PM EST on November 19, 2016
The core of vgmstream has an ISC license. The external libraries for playing MPEG, Ogg Vorbis, G.722.1, G.719, AT3+ (and maybe others in kode54's builds?) each have their own license. When I distribute it I have these all in a "licenses" subdirectory in the zip.
by DrO at 10:21 PM EST on November 21, 2016
There's a range of licenses in effect with the dependent dlls that vgmstream tries to use but they don't appear to prevent them being used like they are (at least not from when I looked at them a few months back).

However it's good to know for certain now what the vgmstream core is actually licensed under (might be handy to have it mentioned on

I had assumed it was something like that though I still need to sort out providing my minor Winamp related changes (which is built against the latest commits from kode54) from the version of in_vgmstream.dll I've built as part of my WACUP project. Dunno if any of those changes will be helpful or not once I've sorted them out but it seems only right I make them available.

by hcs at 9:58 PM EST on November 22, 2016
The COPYING file has always been included with the binary and the source, as far as I can remember.
by Knurek at 7:13 PM EST on November 23, 2016
Has anyone had any luck with those HCA files with encrypted (xored) headers?
There has to be something going on with them, VGMStream plays them as static, but changing the headers to match other HCA files results in lack of playback.

I've seen them used a lot in PSP and Vita games, usually inside UNION.CPK.

edited 7:14 PM EST November 23, 2016
by kode54 at 8:57 PM EST on November 23, 2016
They're encrypted. VGMStream only supports the PSO2 encrypted files, as it has that game's key hard coded. If you want them to play, you'll have to decrypt them.

You'll note that changing just the headers breaks playback. That is because every packet is checksum protected. The encrypted data packets are protected in their encrypted form.

You'll need a decrypter, there's one posted to this forum, on Github, that will, when given a correct encryption key, produce unencrypted files with correct checksums.

I doubt there will ever be any sign of a giant encryption key list built into the player like there is with ADX. Maybe in the filenames of each track, but not through sheer brute force.
by Knurek at 11:33 AM EST on November 24, 2016
Ah, thanks, that clears things up - I've been out of the loop for the past few years.

I managed to find decryption codes for one game, but the devs unfortunately were not lazy here, and haven't reused them between games.

I looked at a 2ch forum post by the guy who posted the code and he mentions going through the PSP exe with a debugger looking for the file load function and getting they key from registers. A bit beyond my skillset, so I will just put the encrypted sets on the archive, alongside with a note mentioning they have no known key and a decrypted PSP executable.
by bnnm at 6:27 PM EST on November 24, 2016
I was thinking about adding a way to read encryption keys from an external file (say "key.bin" or "songname.key"), so you don't have to recompile for new ADX/SCD/HCA/etc keys all the time.
That wouldn't help getting them keys though.

Since I wasn't so sure about FFMpeg I decided to create a separate git with the includes and DLLs.
I use that to build my tests/winamps but perhaps others may use it.
Maybe it could be integrated in the main repo later.
by Nisto at 5:47 PM EST on November 25, 2016
Could I pester you guys with another (couple) format(s)? It's practically just one, really.

Rakugaki Oukoku 2 AKA Graffiti Kingdom (PS2) has two proprietary PSX ADPCM containers with extensions .VDM and .VDS. The headers are identical apart from the IDs.

.VDM files are mono and has magic number 0x56444D20
.VDS files are stereo and has magic number 0x56445320

The structure looks like this:
00 id (4 bytes)
04 size (4 bytes)
08 not sure (4 bytes)
0C sample rate (4 bytes)
10 channel count (4 bytes)
14 interleave size (4 bytes)
18 loop start (4 bytes)
1C loop end (4 bytes)
20 stereo flag (1 byte)
21 volume? (1 byte)
22 pan? (1 byte)
23 ? (1 byte)

Here are some (all) files for testing:

by AnonRunzes at 11:11 AM EST on December 3, 2016
Can anyone here check these files?



These ADX files has an incorrect duration.
by bnnm at 1:21 PM EST on December 3, 2016
@AnonRunzes - They play fine for me, in 6ch.

@Nisto - Adding new formats it's a bit of a pain so you could use GENH for now... I'm considering some easier way to do it though.
by Nisto at 1:56 PM EST on December 3, 2016
Yep, I know bnnm. Was just hoping to get native support added. It's not urgent or anything, but the files are up on Josh W's servers now. It's mostly for the sake of other people being able to actually play them.
by AnonRunzes at 2:27 PM EST on December 3, 2016
Yeah but what about the duration of these files? test.exe can't decode these properly, and in foobar2000 their duration are displayed as 6-7 seconds.
by bnnm at 5:36 PM EST on December 3, 2016
Both foobar and test give me 1:14 and 3:06.

Have you tried updating them? Or maybe you have some plugin conflict in foobar.
by AnonRunzes at 5:42 PM EST on December 3, 2016
@bnnm - Well, perhaps(lol)...
by bnnm at 6:55 AM EST on December 4, 2016
Could somebody help me identify this SGB/SGH variant? (6ch, codec type 5 @ 0x28)

It's the only one of that type I have. I'm guessing some kind of PCM?
by AnonRunzes at 10:56 AM EST on December 4, 2016
@bnnm - Seems to be a new type of PlayStation 4-bit ADPCM.
r1050-120-gef6778b by ckcu at 4:34 PM EST on December 6, 2016
new version r1050-120-gef6778b shows the following error:

Failed to load DLL: foo_input_vgmstream.dll
Reason: This component is missing a required dependency, or was made for different version of foobar2000.
by kode54 at 8:10 PM EST on December 6, 2016
If you read the included README or the component install info page, you'd see there is a new dependencies pack you need to unpack to somewhere in the path of the player, or in the player's own subdirectory. These dependencies are way too large to upload to the official components site.
by vajuvaju at 9:37 PM EST on December 6, 2016

FYI, the link for the external DLLs in the README points to a different .zip file (256KB) than the one in the component install info page (13MB).
VGMStream error? by Bonboon228 at 10:48 PM EST on December 6, 2016
So, I installed the new dependencies for the latest Vgmstream for Foobar.

Upon opening Foobar, I get this message...

Failed to load DLL: foo_input_vgmstream.dll
Reason: The specified procedure could not be found.

Anyone know what I did wrong?
by marcusss at 11:54 AM EST on December 7, 2016
I also updated to the latest VGMStream and downloaded the lib from Kode54

I also tried the link from the readme as well when I uodated vgmstream.. No luck

I extracted to windows system, and Foobar as well as Foobar component but still get same error. Worked fine in the past..

Failed to load DLL: foo_input_vgmstream.dll
Reason: This component is missing a required dependency, or was made for different version of foobar2000.

Now it is stuck on "component not loaded" in component list

edited 11:54 AM EST December 7, 2016

edited 11:55 AM EST December 7, 2016
by vajuvaju at 1:03 PM EST on December 7, 2016
@marcusss @Bonboon228

Don't use the link from the readme. Use the link in the foobar components page.

I copied the DLLs in the same folder as the vgmstream component in my foobar folder and it worked.
by marcusss at 1:46 PM EST on December 7, 2016
I actually used the link from the actual commit page which said to use such link. I would have thought that page would have the latest .

..But yeah I just used the link you mentioned and now it works again. What differences does this version have that requires an updated library??

Anyway progress in VGMStream is always welcomed :) :-)

edited 1:47 PM EST December 7, 2016
Nothing worked? by Bonboon228 at 2:45 PM EST on December 7, 2016
Nope, still errors out for me.

Dll files in same folder as the vgmstream component.

Same error message.

Failed to load DLL: foo_input_vgmstream.dll
Reason: The specified procedure could not be found.

Help please...

Edit: Now that I look at It, it may be the fact that I am using XP and the component simply is not compatible with it. =(

edited 2:53 PM EST December 7, 2016
by bnnm at 5:51 AM EST on December 8, 2016
Bonboon228, can you try downloading the .DLLs here:

Then overwrite those in the foobar plugin folder.
Should be in "C:\Documents and Settings\<username>\Application Data\foobar2000\user-components\foo_input_vgmstream" (Application Data could be hidden)

Original DLLs don't have XP support but maybe those above do.

Some formats will still crash foobar but we are investigating.

edited 5:52 AM EST December 8, 2016
You gotta be kidding me... by Bonboon228 at 8:27 AM EST on December 8, 2016
Now it's throwing up THIS error...

Failed to load DLL: foo_input_vgmstream.dll
Reason: Not a valid Win32 application.

Imma just stick with an previous version of vgmstream...
by kode54 at 7:50 PM EST on December 8, 2016
Sheesh. Does anyone know of any FFmpeg binaries that are XP compatible for all you backwards yahoos that didn't update to Windows 7 10 years ago? Don't give me that "it works perfectly for me" crapola, because clearly this software is not working for you. Morons.

I try to provide XP compatible components, but I can't be expected to build my own XP compatible FFmpeg as well.
by AnonRunzes at 8:33 PM EST on December 8, 2016
@kode54 - That's funny, because when I get foobar2000 to play an normal ATRAC3(not ATRAC3+ as vgmstream previously supported), it just crashed even with the .dll files included. And I'm using Windows 10!
by marcusss at 12:05 AM EST on December 9, 2016
I have been using Win 7 x64 for like forever and only this update I had issues but vajuvaju pointing me to the right link got it working

edited 12:07 AM EST December 9, 2016
by Kurausukun at 11:39 AM EST on December 9, 2016
Just updated my foobar vgmstream component, and now I get the following error:

Failed to load DLL: foo_input_vgmstream.dll
Reason: This component is missing a required dependency, or was made for different version of foobar2000.

I'm on foobar 1.3.13, and I've never needed any other dependencies. Is this a vgmstream bug, or did I goof?

EDIT: Never mind, just checked the components page to find out I DO need some other .dlls. Problem solved.

edited 11:42 AM EST December 9, 2016
by kode54 at 5:51 PM EST on December 9, 2016
Okay, try the latest build. Crashes should be fixed, it was due to a linking problem.

Dependency pack is no longer necessary for foobar2000 package, once again, thanks to some custom building to eliminate all the unneeded parts of FFmpeg.

Check out the ffmpeg_options.txt in the ext_libs directory on the repository, and feel free to suggest any codecs or parsers that should be enabled that aren't already.
by AnonRunzes at 6:41 PM EST on December 9, 2016
Thanks for the latest build, mate. It actually worked this time when it wasn't about struggling to get XMA files to play.

Seriously, is it just me or am I the only one that can't get the .xma files to play on foobar2000 even if I renamed them to .vgms/.vgmstream/.xma.vgms/.xma.vgmstream?

edited 6:46 PM EST December 9, 2016
by bnnm at 7:46 PM EST on December 9, 2016
Nobody can, until the format is actually implemented (if you mean XWB).

edited 7:50 PM EST December 9, 2016
Drama by Bonboon228 at 8:00 PM EST on December 9, 2016
Sorry 'bout all the drama...I did not, (And still don't), have a computer strong enough to run a recent windows os. XP was my only choice, and to make matters worse, the hard drive recently failed on me, so all I have is linux mint...but, such is life.
by Kurausukun at 3:21 AM EST on December 10, 2016
Wait, I'm confused. Is XMA supported in vgmstream somehow now? I saw the last few posts talking about it, but I just tried playing an XMA from Sonic 06 and it didn't recognize it, so I guess not?
by kode54 at 4:13 PM EST on December 10, 2016
XMA must be added partially, since FFmpeg doesn't recognize the loop points. For now, you can hexedit them to find the loop points, and rename them to have a .vgms or .vgmstream extension, but they won't loop.
by AnonRunzes at 6:05 PM EST on December 12, 2016
So, the .ADP file used in Omikron The Nomad Soul isn't supported in vgmstream. In any case, here's the sample:

And yes, I'm aware there is a tool floating around somewhere that can handle these .ADP files. But it doesn't hurt to have this file supported by vgmstream, does it now? I even have the source code if anyone's interested.

Oh, and here's a few hints:
.ADP files used in Omikron The Nomad Soul were encoded with 2 channels and a sample rate of 22050. It uses some kind of ADPCM. It has this header:
0x00-0x03 - size of the file
0x04 - channel count (the value is either 0 or 1; add it by 1)
0x10 - offset of the file

edited 6:44 PM EST December 12, 2016
by bnnm at 3:44 PM EST on December 18, 2016
Latest vgmstream changes:
- added proper/looped .XMA (Xbox360 games)
- fixed Capcom 3DS .MCA v5 (Ace Attourney 6, Monster Hunter 4U)
- fixed Guerrilla .MSS length (Killzone)
- added 3DS .BCWAV dual stereo (Lego games)
- added .hcakey (binary in HCA Decoder format)
- added .pos for .vgmstream (hack for unsupported FFmpeg formats but you can do stuff like song.mp3.vgmstream.pos)

Some XMA notes:
- no 6ch for now (RE6, MvC3, Ace Combat 6, Beatiful Katamari, etc)
- variations later (Namco .xma, Soul Calibur II HD .past, etc)
- many joshw rips are bad (fake XMA1 converted from XMA2 which may play wrong, truncated, poorly extracted from containers with no loop points, etc)
I can check non-working XMA but *please* make sure to post original containers.
by Knurek at 4:28 PM EST on December 18, 2016
Do we have a build(bot) for the latest changes?

As I haven't ripped anything XMA personally, I can't really say what was done with them, but I will gladly accept and upload any fixes.
by AnonRunzes at 6:55 PM EST on December 18, 2016
Is it just me or on foobar2000, the .mss duration issue is the same? I did update vgmstream to the latest version(r1050-147-gad85fc8), so I don't know what's happening if it's just my player acting strange.
by Kurausukun at 8:38 PM EST on December 18, 2016
Just tested with a Sonic 06 XMA, and it works perfectly. Plays at the correct speed, loops correctly, everything. Great work.

One tiny thing I noticed--compared to the output of towav.exe, vgmstream gives me a file with 576 extra samples of silence at the beginning of the track. This also affects the loop points, which are obviously not compensated. The question is, which is right--vgmstream or towav?

I just looked through the files, and going by the metadata, vgmstream/ffmpeg is correct, and it was towav.exe that was wrong all along. Seems strange that nobody said anything until now, but alright.

edited 9:00 PM EST December 18, 2016
by kode54 at 9:18 PM EST on December 18, 2016
What MSS duration issue? Can you boil it down to some actual code?
by AnonRunzes at 9:25 PM EST on December 18, 2016
@kode54 - "What MSS duration issue?"
In foobar2000, intro25k.mss still has this 2:39 duration even after the new version of vgmstream despite these fixes. Which means vgmstream still plays half of the entire audio sample(this issue seems to occur on foobar2000, so maybe it's just my player).

"Can you boil it down to some actual code?"
And I thought that just by reproducing the issue by playing these .mss files was enough.

edited 9:30 PM EST December 18, 2016
by kode54 at 9:33 PM EST on December 18, 2016
The only reference I can find to a "intro25k.mss" is your post right here on this page.
by AnonRunzes at 9:54 PM EST on December 18, 2016
@kode54 - There's a post I made right on that "beta thread" in which I posted two .rar files containing both the original .mss files and .genh files. Check that out.

edited 9:54 PM EST December 18, 2016
by kode54 at 11:02 PM EST on December 18, 2016
Sorry, I wasn't paying enough attention. The issue should be fixed now.
by AnonRunzes at 12:23 PM EST on December 19, 2016

Anyway, here's an .ss2 file from a demuxed PSS that came from the Killzone game.
It doesn't play well on vgmstream.

EDIT: Look, I don't want to be a bother(presumably due to Nisto's advice about these MGS2 audio files) but, is there support for these files yet(aside from GENH)?

I choose .sdx_adpcm as the arbitrary format because ... well, it's sometimes the only way to identify files like these. Anyway, these files came from the following games:
Metal Gear Solid 2 (PS2 - original version) - first two files
Metal Gear Solid 2 (PS2, XBOX - Substance version) - last two files

These files also have different codecs too(indicated by the 0xa offset in each file), hence why I uploaded this .rar file in the first place.

edited 2:53 PM EST December 19, 2016
by bnnm at 6:34 AM EST on December 26, 2016
Could anybody with a fast PC test these XMA in foobar?
When looping I get a second of pause/silence in foobar in the first example, but not in winamp.
XMA looping can be slow, but not all XMA do this for me (maybe bitrate related).

@AnonRunzes - badly demuxed multi-stream ss2, probably. sdx_adpcm no point (no proper header).
Also in general post not one but several samples, non-working and working. Otherwise it's a pain to figure out.

@Kurausukun - good thing you brought this up.
Since towav is (AFAIK) a hacked MS decoder probably it's more accurate.
I tested a bit it does seem like you need to substract 576 to loop correctly, rarely noticeable though (ex. Tales of Vesperia 201).
Apparently MDCT coders (like MP3/XMA/Atrac3) introduce a delay (part of 1 granule = 576 samples), makes sense.
Some XMA headers (not Sonic 06 or ToV) also have a "PlayBegin sample".
Knowing this I'll adjust looping and keep investigating.
by bnnm at 8:38 AM EST on December 27, 2016
Latests vgmstream changes
- Added HEVAG (.vag) [PSVita games], thanks daemon1
- Added "short VAG" SGXD type 5 [Afrika PS3]
- Added Killzone VAGp (.vag)
- Adjusted some VAGp [Ecco the Dolphin]
- Added namco XMA (.xma), Soul Calibur II HD XMA (.past) variations
- test.exe/winamp now use vgmstream's FFmpeg DLLs (delete older avcodec/avformat/avutil DLLs)
- (dev) Added a simple regression testing script for test.exe (also a build doc)
- Removed .vgms (not .vgmstream), as I feel one hack-extension is enough
by kode54 at 6:43 PM EST on December 29, 2016
It's not slow. It decodes at over 230x real time here. The problem is, the first file is emitting several seconds worth of silence before looping.
by bnnm at 8:00 PM EST on December 29, 2016
Well, test.exe gives correct decodes and clear2.xma is the same file but hexeditted to loop one second earlier.
I suspect samples_to_do isn't properly set and always uses max_buffer_samples (in decode_run).
Maybe from the last seek changes?

While testing I also noticed if you disable looping foobar hangs after seeking (maybe infinite while during decode_seek).
Also changing the options doesn't seem to work unless you restart?
by kode54 at 9:15 PM EST on December 29, 2016
I'll let you know what I find on debugging, as apparently only I am able to set up my foobar2000 git repo and build from it.

For now, I have blown away my entire Windows setup again and started from scratch, same product key, new bare metal setup, with the PC as my primary machine once again.

Until I get my hoarded data migrated over to the new Storage Spaces I've arranged, I'll just be mostly idling, or playing the occasional game, or chatting around on IRC while Skyping with my BF.

Once that data migration completes in about 2 hours, I'll unmount the Ext4 partition I copied the data from, clean that drive and add it to the Storage Pool, and rebalance/optimize the thing with PowerShell.

THEN I'll get about the chain of events of reinstalling Visual Studio 2010 Pro and 2015 Community. That usually requires several reboots.


edited 9:15 PM EST December 29, 2016
by bnnm at 8:45 AM EST on December 30, 2016
Ok, sorry. I'll try to fix it later.
by kode54 at 1:00 PM EST on December 30, 2016
Never mind. Nothing to debug yet.

File 1, the loop end is 779136. This appears to include a silence end padding.

File 2, the loop end is 727424. This appears correct.

I disabled looping altogether, and both appear to produce the same file. Mild delays at the start, and that 52000 samples of silence padding on the end.
by McStoat at 11:38 PM EST on December 31, 2016
Sorry if this has been mentioned elsewhere, I looked in the readme and searched around a bit but couldn't find an answer. Do I need anything besides the files included here
to play FFmpeg stuff like .xma? I'm using XMPlay if it makes a difference.
by bnnm at 8:09 PM EST on January 2, 2017
Latests vgmstream changes
- foobar2000: fixed a rare case of silence/0-read at the edge of some files
- Redone FSB1-4: improved XMA/MPEG, bugs
- Added PS ADPCM of configurable frame size (FF XI PC)
- Fixed regression/segfault in multistream .mtaf [MGS3]
- (dev) New utils for common/repetitive actions in stream headers; debug logging utils (disabled by default); fixed some compiler warnings; other cleanups
- Added XWM (non parsed) [Skyrim PC]


@McStoat - it should work if you unzip all .DLL in the XMPlay dir, both the Winamp and XMPlay plugins (I tested with v3.8.2.x).
Here is the latest XMPlay plugin in case it helps:
by Nisto at 8:49 PM EST on January 2, 2017
bnnm, you're doing god's work lately. :) Even though a lot of the formats you've added support for lately haven't exactly been "relevant" for me, I just want to say thanks for all the contributions.

Have you had any time yet to look at the VDS/VDM files from Grafitti Kingdom that I uploaded here a few weeks back? I don't think you'll need much time to implement support for them. Just saying.
by Knurek at 2:35 AM EST on January 3, 2017
I'm ripping Tekken Tag Tournament 2 for WiiU at the moment.
Standard Namco NUS3Bank files, but the IDSP inside come in two versions - standard one which plays fine with VGMStream, and one with _51 in filename (which I'm assuming is coming from 5.1 channels used), which doesn't.

Here's an example: tektag2_idsp
by bnnm at 7:55 PM EST on January 3, 2017
Latests vgmstream changes
- Add SCD OGG v3 decryption (FF XIV Heavensward)
- Basic support for multi-stream SCD (FF XIV sfx, maybe others)
- Add .aa3 and .oma (demuxed PS3 movies)
- (dev) unified supported extensions so all plugins use the same list in formats.c (except foobar2000 Windows assocs)
- (dev) XMPlay plugin can now be built with GCC


@Nisto - I haven't forgotten, but first I'm doing some work to simplify adding new formats.

@Knurek - I could check it but I need more samples. Many more. Ideally a bunch of non-working *and* working ones, to cross reference.
Even better if you can point me to full sets of this and other games using the same format (so I can test I didn't break anything).
by vajuvaju at 10:57 PM EST on January 3, 2017

Great update, especially the aa3/oma support! How are you doing on the XMA front? Please, update this pastebin of yours if you've done any changes:
by McStoat at 6:47 PM EST on January 4, 2017

Thanks a lot for this! The problem turned out to be the .xma themselves, they played fine on ffmpeg but not through XMPlay. I downloaded a different game's .xma set and they play just fine on XMPlay.

Previous Page | Next Page
Go to Page 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27

Search this thread

Show all threads

Reply to this thread:

User Name Tags:

bold: [b]bold[/b]
italics: [i]italics[/i]
emphasis: [em]emphasis[/em]
underline: [u]underline[/u]
small: [small]small[/small]
Link: [url=]Link[/url]


HCS Forum Index
Halley's Comet Software
forum source