Previous Page | Next Page

by Franpa at 11:39 PM EST on January 26, 2010
http://forums.winamp.com/showthread.php?postid=2609518#post2609518

I posted about plugins not working right before, maybe you can prioritize it or something? It's been some time since that post of mine.




----------

Update (5.57 & 5.571 fresh installs):

Installing/updating with "Modern Skin" support selected during the install process, renders VGMStream and MGME input plugins not initializing. Reinstalling without "Modern Skin" support results in the 2 mentioned plugins working fine and dandy.

This is with the plugins and the dll files they depend on, already installed before installing or updating Winamp.

http://hcs64.com/files/vgmstream/
http://mudlord.xtemu.com/files/in_mgme.dll

edited 11:42 PM EST January 26, 2010
by DrO at 7:30 AM EST on January 27, 2010
Franpa: that's the first time i've seen your post and no idea why it wasn't looked into (would have been done if i'd seen it).

i've just installed vgmstream and was getting a crash, loaded up a debug winamp.exe and the crash disappeared so not sure what that was (will have to try again).

have re-run the installer on an install with in_vgmstream present and the supporting dlls and the dll rebaser is handling all of the dll as i thought. from working through things, the issue is coming from the rebasing of libmpg123-0.dll. as a workaround, changing libmpg123-0.dll to read-only makes the rebaser ignore the dll though will look into it closer to see why it is happening but at least there's a workaround for the moment.

is there a current link for in_mgme.dll as the one provided isn't working for me.

-daz

edited 7:32 AM EST January 27, 2010
by Franpa at 8:55 PM EST on January 27, 2010
http://home.exetel.com.au/franpa/in_mgme.dll

It's not the latest version though, not sure where to get that from and I forget what version I tested with.
by Franpa at 12:17 AM EST on January 28, 2010
Also, sometimes when I run Winamp under Windows 7 Home Premium x64, a UAC prompt appears (probably because of MGME?) however the UAC prompt is never given focus. It appears on the Taskbar and flashes and I have to click it to bring it to focus.

Some other times, I get 2 UAC prompts, one with a yellow banner and another with a blue banner, both 1 after the other.

and even still, there are times where there are no UAC prompts.


It's pretty strange. My account is a Admin one and UAC is at the default level.

edited 12:20 AM EST January 28, 2010
by DrO at 8:10 AM EST on January 28, 2010
thanks for the in_mgme.dll link.

well i've had a look at things more closely and the issue appears to come from the import table in the dll's internal structure being altered by the rebaser (is using the BindImageEx(..) api and is as such causing the loading issue.

however by using BIND_NO_BOUND_IMPORTS in the api call it appears to rebase the dll it ok without destroying the import table in libmpg123-0.dll & in_mgme.dll.

why it only affects these dlls is beyond me at the moment though i wonder if it's related to how the dlls have been compiled. either way there's the read-only workaround for the moment though will do what we can to patch the installer's rebaser tool which will hopefully be done in time for the next client release.

as for the UAC stuff (though i'm only just getting upto speed on when it's activated in Winamp), it should only be appearing when a registry access is required (often if the restore file associations option is enabled on loading) or when doing things via the File Types preference page or uninstalling a plugin. however the UAC handling as improved in the 5.572 client so it now works consistantly going on what i've seen personally (Vista+Win7 under admin and standard accounts).

-daz
by Franpa at 4:33 AM EST on January 29, 2010
The erratic UAC encounters probably do match up with the described situations, is there a way to get Winamp to detect when a plugin tries to write to a INI file in the Winamp or Plugin folder and prompt the user for UAC permission?

Otherwise MGME can't remember configuration after closing Winamp unless Winamp is run with admin permissions...
by BtEO at 9:23 AM EST on January 29, 2010
If you've got problematic plugins like that that you must have, install Winamp in portable mode (add no_registry=1 to winamp.ini) *outside of \Program Files\ (yes this part is important)*
by DrO at 9:52 AM EST on January 29, 2010
BtEO: that's a poor method of fixing the issue and really plugin's should be using the correct api to get the directory for saving settings which has been available since 2.9x so there's no excuse for winamp plugins to be created without the correct level of compatability nowadays (or really for anytime in the last 6-7 years).

Franpa: basically in_mgme needs to be updated as above. there isn't a built-in api for detecting such an event as saving settings has always been down to the plugin to implement in a correct and sensible manner (maybe doing a foobar2000 option would make better sense but the relucatance of so many plugin's to be built to work properly under 5.x as it's horrible/evil/bloated/etc etc as i keep seeing from comments is no wonder there are the issues being experienced).

back to the original issue and unless i can figure out what is done differently with the compiles of in_mgme and libmpg123-0.dll, they'll just be black-listed from being rebased (though i'd prefer a method which automatically copes with such dlls as i've a feeling there are other cases out there).

-daz
by BtEO at 1:13 PM EST on January 29, 2010
That's why I added the 'must have' clause.
by Hotcakes at 8:18 PM EST on January 29, 2010
Hmm, on the subject of Winamp 5.x, shitty old plug ins, compatibility and source, I wonder if someone could take a look at the source for the MED plug-in:

http://www.theess.com/med-soundstudio.html

I contacted the author who said they're not interested in Winamp or MED any more, so I'm boned. Basically it suffers from the re-basing issue (not a huge deal) and now I can't get it to play anything without crashing (worked pre-5.57). Then again, it was never a very good piece of code, even back in the 2.x days.

Previous Page | Next Page
Go to Page 0 1 2 3 4 5 6 7 8

Search this thread

Show all threads

Reply to this thread:

User Name Tags:

bold: [b]bold[/b]
italics: [i]italics[/i]
emphasis: [em]emphasis[/em]
underline: [u]underline[/u]
small: [small]small[/small]
Link: [url=http://www.google.com]Link[/url]

[img=https://www.hcs64.com/images/mm1.png]
Password
Subject
Message

HCS Forum Index
Halley's Comet Software
forum source
Generated in 0.0033s;