Previous Page | Next Page

by Brightstar at 6:57 AM EST on March 6, 2021
VGMToolbox has been a great tool for decrypting audio however I’m running into an issue now. I’m not sure if something is happening with the key randomly in some of these files but when I go to decrypt some of the music from Phantasy Star Online 2 New Genesis randomly some of the music is coming out corrupted. It plays fine within the game but it’s just a digital audio mess when played back. Most segments are fine and don’t have any issues.

The song begins as a compressed .cpk (231c67721735cad54dbccde2317e50) file which is then uncompressed into the multi-segment track. From there I load up foobar2000 with the VGMToolBox plugin to then convert the .hca files into .wav. Randomly the conversion fails and gives me digital garbage instead.

(Maybe this is part of the problem but the regular VGMToolBox.exe gets stuck in an endless loop of trying to extract the .hca and instead it fails and just creates a folder with the same .hca inside of it.)

I’ve set up a share folder an example. https://easyupload.io/ng450x These files combine into a single track when played in order (so just throw them into a playlist.) In this case the following came out corrupted.

etamb t138 b4 028
etamb t138 b4 036
etamb t138 b4 089
etamb t138 b4 096
etamb t138 b4 106
etamb t138 b4 114

Any idea what might be happening and if a fix can be done?
by Brightstar at 11:29 AM EST on March 6, 2021
My mistake, earlier I referred to a VGMToolBox foobar2000 plugin, I meant to say VGMStream there.
by bnnm at 12:09 PM EST on March 6, 2021
HCA are encrypted, and vgmstream tries to figure out which key is better for the file.

Since some of those segments are rather noisy (clip a lot) key detector gets confused and picks the wrong one.

Not sure how to improve detection so for now you can tell vgmstream which key to use by unzipping this in the hca folder: https://easyupload.io/lorltx
by bnnm at 4:23 PM EDT on March 14, 2021
I had a flash of inspiration and improved HCA key detection, so you don't need to do that anymore.
Genshin Impact key by Someone at 8:46 AM EDT on July 24, 2021
I'm trying to find the key for the video for Genshin Impact.
So, I de-encrypted the global-metadata.dat file, but I'm lost now. What should I look for in the file, where should I look? I tried importing the folder into AssetStudio but the app would just crash. What should I do?
Where am I doing wrong?
by StarWolf3000 at 7:33 AM EDT on July 27, 2021
@Someone
Does Genshin Impact even have any video data? I think everything is rendered in real-time during execution.
Yes by Someone at 9:37 AM EDT on July 29, 2021
Yes it does, I got all the USM files, and audio extract as usual. Just the audio.
Funny though, most cut-scenes can be rendered on the go, but they chose to explicitly render some scene, like ayaka dance, or the boss fight aftermaths, I think to help adding environment effects that can be too hard to render on the go.

Set render resolution to 0.6, you should notice some sections that is way clearer then it should be under that resolution, these are the videos.
by dmage at 12:40 AM EDT on August 7, 2021
Hello everyone, I hope this is the right place to post.

I'm trying to extract acb/awb from an android game Ulala Idle Adventure. Here is the apk and one sample of acb and awb files.


What I've done so far:
- Downloading VGMToolbox and installing vgmstream plugin on foobar.
- Drag-and-dropping the awb file directly into foobar revealed five playable tracks but all of them produced static noise.
- When using VGMToolbox's Common Archives - CRI ACB/AWB Archive Extractor, it created acb/awb folder and awb folder. The former had five hca tracks but all of them had zero byte; the latter had five bin tracks but all of them also zero byte.
- When using VGMToolbox's Streams - CRI HCA Extractor, it created five playable hca files (not zero byte), but all of them also produced static noise; pretty much the same noise with the first case (drag-and-dropping directly into foobar)

If my understanding is correct, the acb/awb file is encrypted and VGMToolbox just picked a wrong key to decrypt. Is that correct? But I have no luck finding the key among the data files, and even if I know the key, I still don't know how to tell VGMToolbox to extract using the said key. I actually have tried other tools like quickbms, vgaudio and vgmstream but nothing produces better than what VGMToolbox has achieved.
by bnnm at 1:30 PM EDT on August 9, 2021
If awb have noise that means key is missing from the known list.

You can add your own key by making a binary ".hcakey" file with the key (8 bytes) in the same folder and playing with foobar/vgmstream, shouldn't extract with vgmtoolbox these kind of files.

Gave a look but didn't find it in typical key locations, maybe they are in the (encrypted?) .lua files or something.
by dmage at 10:16 PM EDT on August 9, 2021
@bnnm

I still have no clue where to find this key. Couldn't find anything with .lua either. Does uploading the "Android/data/com.xxx" folder to you have any effect? I checked the folder and it has around the same size as the apk itself.

The obb file is very huge (one file whose size is more than 1 Gb). I don't think the key is hidden somewhere in this file, but it's never hurt to ask. If my assumption turns out to be false, then I'll upload the file later.

Beside these two locations, is there any possibility of other locations to be checked? Like the location of the aforementioned possibly-encrypted .lua file?

Previous Page | Next Page
Go to Page 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35

Search this thread

Show all threads

Reply to this thread:

User Name Tags:

bold: [b]bold[/b]
italics: [i]italics[/i]
emphasis: [em]emphasis[/em]
underline: [u]underline[/u]
small: [small]small[/small]
Link: [url=http://www.google.com]Link[/url]

[img=https://www.hcs64.com/images/mm1.png]
Password
Subject
Message

HCS Forum Index
Halley's Comet Software
forum source