Previous Page | Next Page

by RukarioGyiyg996 at 11:10 AM EST on January 26, 2014
libmodplug is OLD... VERY ANCIENT and does not correspond whatosever to OpenMPT's loaders. libmodplug is basically a library port of the old ModPlug Player program for Windows.

OpenMPT is for windows yes, but it's source is open and the loader code surely isn't limited to just windows and can be ported. Probably a bit complicated to port atleast to me since I know nothing of C++ and only barely a tinge of C but as far as I know Android programs aren't even WRITTEN in C.

xmp is a Linux native module replayer that can play esoteric formats but for reasons I can't yet understand OpenMPT plays these esoteric formats WAY WAY better than xmp ever did. Which is why I would love it if droidsound had the loader code from OpenMPT in use so I don't have to constantly fail to make S3M files out of some oddball formats and have them sometimes sound completely different.
by haspor at 12:47 PM EST on January 26, 2014
I was checking libopenmpt earlier and I think it is possible to integrate it to Droidsound. Android applications can use native C/CPP code. I'll try this later.
by haspor at 12:48 PM EST on January 29, 2014
latest prebuilt binary has libOpenMPT, check it out. If there is some problem with some formats it tries to play, forward these issues to openMPT bugs page directly.
by JFD62780 at 7:44 PM EST on January 29, 2014
...My only complaint would be how would I DOWNLOAD the thing?

Should I choose debug-aligned or debug?

I have a Samsung Galaxy S4, BTW, and I tried downloading the file directly using Dolphin Browser, and the system tells me, "There is a problem parsing the package".

EDIT: How do I download WITHOUT having to 'join' GitHub? They want my 'credit' card number EVEN if I choose 'Free'! :(

EDIT DEUX: Figured out the download problem; Shoutcast streaming STILL doesn't work on my phone; it mainly hangs on trying to buffer the network stream. (Android 4.3)

Also, you rock for figuring out the meaning of my previous post! libOpenMPT's sound system RULES!!! :D

edited 9:19 PM EST January 29, 2014
by RukarioGyiyg996 at 4:28 AM EST on January 30, 2014
I also wonder if droidsound can get adplug preferably with dbopl.c from the DosBOX project as the emulation core.

Deadbeef player has an "adplug" plugin but it sounds TOTALLY wrong...

I really need to learn how to program android crap...
by xamp at 7:34 AM EST on January 30, 2014
For some reason, the latest build doesn't play any of my *.psf files and the option to change from highly experimental to sexyPSF is gone.
by Level99 at 4:13 PM EST on January 30, 2014

sexyPSF was removed after testing in December and January for two reasons. 1) Testing at the time showed no difference in compatibility between the two plugins and 2) that if sexyPSF was selected, no PSF2 files would play due to how the plugins were arranged. It was a redundant plugin.

Which PSF files are you trying to play?

Also, again to reiterate, report issues on the GitHub page. It's definitely helped haspor to keep everything localized there.



I just tried loading the SceneSat m3u shoutcast file and it worked after a little finagling. Try loading the file, hitting stop, then pressing play again.

Edit: Also, I've been slowly working on the Wiki to provide more information to folks. Here are the instructions on how to install Droidsound:

edited 4:23 PM EST January 30, 2014
by RitzierHades63 at 10:05 PM EST on January 31, 2014
Sorry for not replying earlier, haspor. I lost track of this for awhile.

I am using a 7 inch tablet from Emerson, model # EM744.

I don't see a settings icon anywhere in Droidsound. Only buttons I'm seeing are forward, backward, stop, pause, Seq/Rnd, Hold/Cont, and + (to add to favorites). I guess I have the permissions problem you mentioned earlier? Any way I can give Droidsound the necessary permissions?

And yes, like Sir Sabin mentioned, I don't have physical buttons at the bottom of my tablet. Only physical buttons I have are Sleep and Volume Up/Down.

Thanks for listening
by xamp at 6:42 AM EST on February 1, 2014
I'm playing minipsfs from final fantasy VII, legend of legaia, Strider2,and psfs from final fantasy VIII and legend of mana none of which play any sound. They all display. The plugin as UADE and the format as sound factory.
**problem solved**
edited 7:19 AM EST February 1, 2014

edited 11:32 AM EST February 1, 2014
by RukarioGyiyg996 at 2:45 PM EST on February 1, 2014
I can't seem to install the apk, it bitches that it fails to parse the package. I also noticed the package has no icon either... is github failing to give me the file properly?

EDIT: I'm running Android Gingerbread by the way. I had no problems installing swimsuitboy's droidsound off of the google play market.

edited 2:49 PM EST February 1, 2014

Previous Page | Next Page
Go to Page 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16

Search this thread

Show all threads

Reply to this thread:

User Name Tags:

bold: [b]bold[/b]
italics: [i]italics[/i]
emphasis: [em]emphasis[/em]
underline: [u]underline[/u]
small: [small]small[/small]
Link: [url=]Link[/url]


HCS Forum Index
Halley's Comet Software
forum source