forum meta viewport by hcs at 12:18 AM EDT on April 16, 2017
I've just set a viewport meta tag on the forum, this should make it less painful to read on mobile browsers. Let me know if there are any unwanted side effects.

edited 12:19 AM EDT April 16, 2017

edited 12:19 AM EDT April 16, 2017
by snakemeat at 11:31 AM EDT on April 16, 2017
Just experienced for the first time. Great job. I will let you know if I find any quirks.
by hcs at 3:27 PM EDT on April 16, 2017
I was expecting to have to mess with the CSS, but just adding the common <meta name="viewport" content="width=device-width, initial-scale=1"> was enough for a huge improvement.
by ArcticJaguar725 at 3:23 AM EDT on April 19, 2017
Not sure if this is related to the meta tag or not, but I've found that I had to redo the URLs for my bookmarks around the same time this was added because they kept navigating me to some kind of invalid page. Just recently I've found that I can't actually log out of my account for some reason, and I'm getting a similarly looking error to that of the first one. To be fair, I was trying to log out and back in on mobile because I wasn't able to post anything due to an authentication error of some sort so that could also be a related issue, but I'm scared to try that again on my PC because there's a slight possibility the login screen has the same error, and I could be permanently locked out.
by hcs at 4:41 AM EDT on April 19, 2017
Crap, you're right, the cookies don't work anymore, I need to set the header before I send any content. I didn't notice as I rarely log in. Will fix immediately.

I'm not sure what the deal is with your bookmarks, though, the URLs didn't change afaik.

edited 4:43 AM EDT April 19, 2017

Oh, you probably have bookmarks to http://, and this change also broke the http -> https redirect, which also needs to send a header. Double crap.

edited 4:49 AM EDT April 19, 2017

Should be fixed now, sorry about all that. I wonder if this is also what G-Boy ran into here.

edited 4:57 AM EDT April 19, 2017
by G-Boy at 12:50 PM EDT on April 19, 2017
@ArcticJaguar725 Regarding the "Authentication failed" message, I had the same problem! I fixed it by deleting the site's cookies.

edited 12:51 PM EDT April 19, 2017
by ArcticJaguar725 at 4:49 PM EDT on April 19, 2017
Yeah, logging out and back in should've done the trick since that basically does the same thing. However, it was bugged at the time and didn't work.


Go to Page 0

Search this thread

Show all threads

Reply to this thread:

User Name Tags:

bold: [b]bold[/b]
italics: [i]italics[/i]
emphasis: [em]emphasis[/em]
underline: [u]underline[/u]
small: [small]small[/small]
Link: [url=http://www.google.com]Link[/url]

[img=https://www.hcs64.com/images/mm1.png]
Password
Subject
Message

HCS Forum Index
Halley's Comet Software
forum source
Generated in 0.0039s;