Previous Page | Next Page

by kode54 at 9:15 PM EST on December 29, 2016
I'll let you know what I find on debugging, as apparently only I am able to set up my foobar2000 git repo and build from it.

For now, I have blown away my entire Windows setup again and started from scratch, same product key, new bare metal setup, with the PC as my primary machine once again.

Until I get my hoarded data migrated over to the new Storage Spaces I've arranged, I'll just be mostly idling, or playing the occasional game, or chatting around on IRC while Skyping with my BF.

Once that data migration completes in about 2 hours, I'll unmount the Ext4 partition I copied the data from, clean that drive and add it to the Storage Pool, and rebalance/optimize the thing with PowerShell.

THEN I'll get about the chain of events of reinstalling Visual Studio 2010 Pro and 2015 Community. That usually requires several reboots.

Grr.

edited 9:15 PM EST December 29, 2016
by bnnm at 8:45 AM EST on December 30, 2016
Ok, sorry. I'll try to fix it later.
by kode54 at 1:00 PM EST on December 30, 2016
Never mind. Nothing to debug yet.

File 1, the loop end is 779136. This appears to include a silence end padding.

File 2, the loop end is 727424. This appears correct.

I disabled looping altogether, and both appear to produce the same file. Mild delays at the start, and that 52000 samples of silence padding on the end.
by McStoat at 11:38 PM EST on December 31, 2016
Sorry if this has been mentioned elsewhere, I looked in the readme and searched around a bit but couldn't find an answer. Do I need anything besides the files included here https://github.com/bnnm/vgmstream-builds
to play FFmpeg stuff like .xma? I'm using XMPlay if it makes a difference.
by bnnm at 8:09 PM EST on January 2, 2017
Latests vgmstream changes
- foobar2000: fixed a rare case of silence/0-read at the edge of some files
- Redone FSB1-4: improved XMA/MPEG, bugs
- Added PS ADPCM of configurable frame size (FF XI PC)
- Fixed regression/segfault in multistream .mtaf [MGS3]
- (dev) New utils for common/repetitive actions in stream headers; debug logging utils (disabled by default); fixed some compiler warnings; other cleanups
- Added XWM (non parsed) [Skyrim PC]

***

@McStoat - it should work if you unzip all .DLL in the XMPlay dir, both the Winamp and XMPlay plugins (I tested with v3.8.2.x).
Here is the latest XMPlay plugin in case it helps:
https://www.sendspace.com/file/yjbuzj
by Nisto at 8:49 PM EST on January 2, 2017
bnnm, you're doing god's work lately. :) Even though a lot of the formats you've added support for lately haven't exactly been "relevant" for me, I just want to say thanks for all the contributions.

Have you had any time yet to look at the VDS/VDM files from Grafitti Kingdom that I uploaded here a few weeks back? I don't think you'll need much time to implement support for them. Just saying.
by Knurek at 2:35 AM EST on January 3, 2017
I'm ripping Tekken Tag Tournament 2 for WiiU at the moment.
Standard Namco NUS3Bank files, but the IDSP inside come in two versions - standard one which plays fine with VGMStream, and one with _51 in filename (which I'm assuming is coming from 5.1 channels used), which doesn't.

Here's an example: tektag2_idsp
by bnnm at 7:55 PM EST on January 3, 2017
Latests vgmstream changes
- Add SCD OGG v3 decryption (FF XIV Heavensward)
- Basic support for multi-stream SCD (FF XIV sfx, maybe others)
- Add .aa3 and .oma (demuxed PS3 movies)
- (dev) unified supported extensions so all plugins use the same list in formats.c (except foobar2000 Windows assocs)
- (dev) XMPlay plugin can now be built with GCC

***

@Nisto - I haven't forgotten, but first I'm doing some work to simplify adding new formats.

@Knurek - I could check it but I need more samples. Many more. Ideally a bunch of non-working *and* working ones, to cross reference.
Even better if you can point me to full sets of this and other games using the same format (so I can test I didn't break anything).
by vajuvaju at 10:57 PM EST on January 3, 2017
@bnnm

Great update, especially the aa3/oma support! How are you doing on the XMA front? Please, update this pastebin of yours if you've done any changes: http://pastebin.com/reHUDMtr
by McStoat at 6:47 PM EST on January 4, 2017
@bnnm

Thanks a lot for this! The problem turned out to be the .xma themselves, they played fine on ffmpeg but not through XMPlay. I downloaded a different game's .xma set and they play just fine on XMPlay.

Previous Page | Next Page
Go to Page 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151

Search this thread

Show all threads

Reply to this thread:

User Name Tags:

bold: [b]bold[/b]
italics: [i]italics[/i]
emphasis: [em]emphasis[/em]
underline: [u]underline[/u]
small: [small]small[/small]
Link: [url=http://www.google.com]Link[/url]

[img=https://www.hcs64.com/images/mm1.png]
Password
Subject
Message

HCS Forum Index
Halley's Comet Software
forum source
Generated in 0.0195s;